Some problems with my new CRB

View previous topic View next topic Go down

Some problems with my new CRB

Post by Keef the Thief on Sun May 04, 2014 9:39 am

Hi everybody

After the first 100 rounds (Remington UMC 230gr, golden/yellow bullet), I had the following problems/symptoms:

- the gun jammed 3 times. The round was jammed between the bolt and the barrel entrance and the round was compressed/clinched.
- every single shell was covered with massive carbon
- strong production of black smoke outside of the extractor
- massive fire/sparks outside of the extractor


Common "features" or STOP Shooting imediately?

Thank you for your help.

Keef


Last edited by Keef the Thief on Mon May 26, 2014 7:17 am; edited 2 times in total

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Re: Some problems with my new CRB

Post by MadDogDan on Mon May 05, 2014 4:14 pm

Stop shooting immediately.  That is not normal or even common.  Sounds like an out of spec chamber which I believe could cause "all" of the problems you mentioned. I shoot my SBR suppressed which should cause more backpressure and my empty casings are still pretty clean with not black smoke or sparks. Something doesn't sound right.

JMHO,
MadDog

MadDogDan

Posts : 175
Join date : 2013-03-20

Back to top Go down

Sounds about par for the course

Post by Mattrog on Mon May 05, 2014 4:31 pm

Mine jams reguarly, even w/ approved ammo.  The Remington Saber rounds seem especially dirty and leave my trigger finger black.

Mattrog

Posts : 21
Join date : 2013-05-19

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Thu May 15, 2014 7:55 am

I've sent back my CRB to KRISS. I hope they don't need to long...

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Re: Some problems with my new CRB

Post by gubi on Thu May 15, 2014 5:46 pm

Mine took about 2 months, but they seem to have improved it.

gubi

Posts : 17
Join date : 2013-11-17

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Wed May 28, 2014 11:13 am

Today, my CRB was fixed and is on the way back to me. KRISS (Thank you Marc) has changed the bolt and have done some finetuning operations, like polishing the feedramp and also polishing the frame angle at the ejector port place.

I’ll test fire the CRB asap and tell you the results.

Keef


Last edited by Keef the Thief on Mon Jul 14, 2014 12:08 pm; edited 1 time in total

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Question

Post by ftmontez on Sat May 31, 2014 11:39 pm

Keef,

How long did it take for KRISS to take any action? I'm having the same problems. Thanks,

frank

ftmontez

Posts : 2
Join date : 2014-05-31

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Sun Jun 01, 2014 4:54 pm

Hm, over all, it was about two and a half week. But it was an Keep-in-Switzerland-Repair.

Keef


Last edited by Keef the Thief on Mon Jul 14, 2014 12:09 pm; edited 1 time in total

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Question

Post by ftmontez on Sun Jun 01, 2014 9:08 pm

Thank you Keef,

Shoot on!

ftmontez

Posts : 2
Join date : 2014-05-31

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Thu Jun 05, 2014 4:21 pm

Oh my... I hate it. Another 100 rounds; another 4 F-T-F!!

I'm waiting on Kriss's answer. Otherwise, I'll give the CRB back to my dealer.

Keef

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Fri Jun 13, 2014 7:30 am

Got two new 25+ mags from KRISS. I've tested the gun with American Eagle ammo and again; I had 5 Fail-To-Feed's!!!!

F*********K; I love the design, I like the company, but what happens here, is incredible!! About 400 rounds and more than 15 FTF's with new mags, polished parts...unbelievable!

Keef

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Sun Jul 13, 2014 1:55 pm

After sending back my CRB to KRISS for another repair, I reveived a completly new one last saturday. Thank you Guys. I shot 150 rounds (100 American Eagle, 50 Remington) and had again 2 Fail-To-Feeds. But this time, they was common "Second-to-last-round"-Problems with the Extended Mags; no other F-T-F's.

I'm looking forward with my new model. I'll kepp you gyus informed.

Keef

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Re: Some problems with my new CRB

Post by TexasEagle on Mon Jul 14, 2014 10:06 am

Keef the Thief wrote:After sending back my CRB to KRISS for another repair, I reveived a completly new one last saturday. Thank you Guys. I shot 150 rounds (100 American Eagle, 50 Remington) and had again 2 Fail-To-Feeds. But this time, they was common "Second-to-last-round"-Problems with the Extended Mags; no other F-T-F's.

I'm looking forward with my new model. I'll kepp you gyus informed.

Keef

Hey Keef,

Read this thread: http://www.krisstalk.com/t1107-stovepipe-problem-with-kriss-mags-likely-solved

Hope that helps.

_________________
Hokey religions and ancient weapons are no match for a good blaster at your side, kid." ~ Han Solo

TexasEagle

Posts : 31
Join date : 2013-03-24

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Mon Jul 14, 2014 12:05 pm

Hey TexasEagle

Thank you for the link; i'll try this out. Sounds logic.

Keef

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Fri Jul 25, 2014 6:09 am

Hi folks

Yesterday, I was at the range again with my exchanged CRB and test fired it with 100 Remington Bullets. I had 4 stock 13-Rounders and 2 extended 25's (new ones, 24 Rounds per mag).

Finally, there is a new phenomenon, I never had before. It happens only with the stock mags and with all of them.
After firing the last round, the bolt doesn’t keep open. Instead, he tried to feed another bullet. The result was a “loaded” but empty gun!

Then, with the extended mags, one had the problem with the second-to last round, who always fails to feed. Then there was a non-properly ejected shell, who was jammed between the bolt AND a stovepiped round!! Incredible!!

The other extended mag “hangs” after about the 14th round. I pulled the mag out and there was no more spring pressure in it. The next bullet felt out of the mag (because no pressure) and the following bullets doesn’t came up.

Now I have shoot with six extended mags and ALL of them doesn’t work properly. And now, there is the problem with the stock mags…..

For my opinion, there was too much problems for a freshly new gun.

I'm waiting on KRISS's answer... I'm not happy :-(

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Re: Some problems with my new CRB

Post by Keef the Thief on Sun Sep 07, 2014 2:11 pm

Hi Guys

It's time for an update. I've talked with KRISS about the open bolt problem and they send me an new piece of "Bolt Stopper" Hardware.

After the exchange; I've seen the origin of my problem:



With the new part; there are no more problems. I've tried 100 rounds of Remington and had no single FTF with the stock 13 mag's. For me, I dont need the extended mags no longer, because they only make trouble.

Keef

Keef the Thief

Posts : 17
Join date : 2014-05-04

Back to top Go down

Re: Some problems with my new CRB

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum